ACH Processing Issues

Incident Report for Sola

Resolved

This incident has been resolved.
Posted Nov 23, 2025 - 10:14 EST

Investigating

We are receiving reports of intermittent ACH transaction processing errors. We will update as more information becomes available.
Posted Nov 22, 2025 - 23:46 EST
This incident affected: Partners (ProfitStars).