Delayed Batch Settlement

Incident Report for Sola

Resolved

We have identified and resolved the batch settlement issue. Any affected batches will be funded with a delay of one day.
Posted May 14, 2025 - 11:46 EDT

Investigating

A small subset of our merchants may be experiencing a delay in batch settlement. This may cause funding to be delayed. We are investigating and will update once we have additional information.
Posted May 14, 2025 - 09:08 EDT