USAePay Transaction Processing Issues

Incident Report for Sola

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 12:38 EDT

Identified

We are aware of processing errors occurring on USAePay transactions. We will update as more information becomes available.
Posted Jul 04, 2025 - 10:46 EDT
This incident affected: Cardknox Services (Transaction Processing) and Partners (USAePay).