3rd Party Power Outage

Incident Report for Sola

Resolved

This incident has been resolved.
Posted May 25, 2025 - 12:10 EDT

Identified

We are aware of a 3rd party power outage that is affecting some of our internal systems, including our phone systems.

If you are having trouble reaching our internal teams by phone, please reach out via email to techsupport@solapayments.com.

All merchant and partner-facing systems are currently operational.
Posted May 25, 2025 - 09:09 EDT
This incident affected: Partners (Other).