ACH Transaction Processing Issues

Incident Report for Sola

Resolved

The ACH issue has been resolved and processing has returned to normal.
Posted Sep 19, 2025 - 13:56 EDT

Investigating

We are receiving reports of intermittent ACH transaction processing errors. We will update as more information becomes available.
Posted Sep 19, 2025 - 13:06 EDT
This incident affected: Sola Services (ACH Processing).